Opened 11 years ago

Closed 11 years ago

#925 closed defect (fixed)

Fix SVG output for batik

Reported by: osm@… Owned by: Jochen Topf
Priority: minor Milestone:
Component: osmarender Version:
Keywords: Cc:

Description

There is an issue when using batik to render tiles that causes grey edges to appear. It appears to be caused by the fact that inkscape and batik do different things when rendering non-square tiles. The fix is ofcourse to make the tiles square.

<snip>

I had here a method to do it by hand, however, it turns out that preserveAspectRatio="none" in the <svg> does the right thing. Patch attached.

Attachments (1)

aspect.patch (457 bytes) - added by osm@… 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by osm@…

Attachment: aspect.patch added

comment:1 Changed 11 years ago by lh

Please commit this. I like batik ;D.

comment:2 Changed 11 years ago by Deelkar

Resolution: fixed
Status: newclosed

This seems to fix the issue, thanks

Note: See TracTickets for help on using tickets.