Opened 11 years ago

Closed 11 years ago

#942 closed defect (fixed)

Markers. mlat, mlon URL parameters have stopped working

Reported by: Harry Wood Owned by: Tom Hughes
Priority: critical Milestone:
Component: mapnik Version:
Keywords: URL mlat mlon marker Cc:

Description

mlat, mlon URL parameters have stopped working This is the marker functionality as described at http://wiki.openstreetmap.org/index.php/Browsing#Adding_a_Marker

example URL: http://www.openstreetmap.org/?mlat=51.57&mlon=-0.21&zoom=6

Don't know why they've stopped working. Can someone investigate?

I'd say this is URGENT actually. There may be a lot of websites using mlat mlon URL params in their links. I know wikipedia does. Currently all missing their markers.

...anyway hopefully it's just a little bug somewhere.

Attachments (1)

942.patch (914 bytes) - added by Thomas Wood 11 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 11 years ago by Tom Hughes

They haven't really - your cookie is turning the marker layer off. If you clear your osm cookies it should work again. I need to work out why the change I made to the layer parsing isn't quite working...

comment:2 Changed 11 years ago by Thomas Wood

Cookies are not the issue here, I've cleared mine and the issue is still occuring.

I believe the issue to be caused by setMapLayers being triggered when mlat/mlon is passed and no layers param.

This issue has only just become apparent as a result of Tom's changes in r7872. If you call setMapLayers("B00T"), the markers layer will become hidden although it should remain as the default.

Patch attached to fix both issues.

Changed 11 years ago by Thomas Wood

Attachment: 942.patch added

comment:3 Changed 11 years ago by tomhughes

Resolution: fixed
Status: newclosed

(In [8055]) Don't try and parse an empty string as a layer config, and cope a bit better if we do hit the end of the string. Closes #942.

Note: See TracTickets for help on using tickets.