Opened 7 years ago

Closed 5 years ago

#4430 closed defect (duplicate)

[landcover] rendering of desert

Reported by: jahudie@… Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: desert rendering zoomlevel Cc:

Description

I know that till today the proposal of the desert feature is not approved (http://wiki.openstreetmap.org/wiki/Proposed_features/Deserts) but it is rendered in Mapnik already.

The problem is the kind of way the desert is rendered today. The rendering doesn't make sense at all as you can see here: http://www.openstreetmap.org/?lat=30.374&lon=34.836&zoom=9&layers=M

############

  1. The color

############

The color needs to be changed as it doesn't make sense to show a desert that dark in brown. Desert should not be darker than a forest and as there is a lot of life and also villages in this area. The desert shouldn't be that present in Mapnik!

############

  1. The desert name

############ The name of the desert is not showing at all at the moment. This is of course not very helpful. If a big desert is defined it should on some zoomlevels show the name of the desert.

############

  1. zoomlevel that show desert

############

currently the zoomlevel = showing of desert doesn't make sense. The desert gets rendered already in zoom=8 in dark brown. The same way as the forest gets rendered in zoom=8. In zoom=9 the landuse farmland is rendered and in zoom=10 also landuse=sand is added. It looks very much like a swiss cheese.

In zoom=13 there is no desert rendered anymore.

############ Summary ############

The whole concept of showing the desert has to be reconsidered. The current displaying doesn't make so much sense.

We consider in Israel to remove the whole desert just because it is showing this strange way. I know that we shouldn't map to a renderer but in this case it looks just to bad to keep it this way.

Please see this thread in the discussion board: http://forum.openstreetmap.org/viewtopic.php?id=14806

Change History (2)

comment:1 Changed 5 years ago by math1985

Summary: rendering of desert[landcover] rendering of desert

comment:2 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed

This issue is now being discussed on Github: https://github.com/gravitystorm/openstreetmap-carto/issues/773

Therefore, I will close the issue here.

Note: See TracTickets for help on using tickets.