Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4851 closed defect (fixed)

Permalink unaware the user has clicked 'browse map data'

Reported by: Dan Jidanni Jacobson Owned by: rails-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

Google Maps permalinks do not do such switcheroos:

We click 'browse map data' and then click permalink, thinking that is what we will be sharing...

But alas it is not.

Same probably for Browse Map Notes checkbox.

Make sure permalinks aren't doing bait and switch!

Change History (6)

comment:1 Changed 6 years ago by Tom Hughes

They also don't remember that you've done a search, or opened the map key, or the export tab, or any number of other things.

comment:3 Changed 6 years ago by Tom Hughes

I think this is also a duplicate of point 3 on https://trac.openstreetmap.org/ticket/4850 though it's a bit hard to parse that.

comment:4 Changed 6 years ago by Dan Jidanni Jacobson

My bug report is the clearest of them all. The user clicks cycle map, that is remembered in a permalink he then creates. Same with the other map types below it. But then when he adds one of the checkboxes right below them still... sorry, not included in the permalink.

comment:5 Changed 6 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

The notes layer is now persisted by a7e6784/rails. We don't think it would be appropriate to persist the data layer because previous experience tells us that it's very easy for people to unintentionally give out links which have the data layer on and the user experience when visiting those links is poor and also expensive in terms of server resources.

comment:6 in reply to:  5 Changed 6 years ago by Dan Jidanni Jacobson

Replying to TomH: OK, but then when they turn on a layer which you aren't going to deliver, then 1) hide the permalink, or 2) pop up some alert upon click telling them what's (not) going to happen. Also let them know how to make such a permalink just in case they really really want to.

Note: See TracTickets for help on using tickets.