Opened 4 years ago

Closed 2 years ago

#5289 closed defect (fixed)

If "background imagery" list is too long, you can't select the "vector file" option

Reported by: SomeoneElse Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: imagery Cc:

Description

"Vector file" is needed to be able to select waypoints (decent waypoint handling is something that P2 does that none of the other OSM editors - with the exception of P1 - do).

On a Windows 7 laptop with SeaMonkey? as the browser, with the browser at a "normal size to use" I see nothing below "sharpen".

The "root cause" of this is arguably the same as https://trac.openstreetmap.org/ticket/5208 - an over-long imagery list full of antique maps that really aren't any use for everyday mapping (but, as pnorman pointed out on that ticket, insisted on by people who like to look at old maps) - but that's ticket 5208. This ticket is trying to say "if the imagery list is that long for whatever reason, truncate it, or make it scrollable, or reorder it or something else so that the "Vector File" option is still accessible.

Change History (1)

comment:1 Changed 2 years ago by Richard

Resolution: fixed
Status: newclosed

Fixed, so there'll be a scrollbar if it would be bigger than the (initial) screen height. (It doesn't resize if you resize the window, though. That way lies Flash binding madness.)

Note: See TracTickets for help on using tickets.