Opened 17 months ago

Last modified 12 months ago

#5489 new enhancement

Should move to Netty 4

Reported by: FauxFaux Owned by: bretth
Priority: critical Milestone:
Component: osmosis Version:
Keywords: Cc: sebastic

Description

Osmosis is using Netty 3, which upstream dropped support for in 2016. Netty is important for security, so it's important to use a supported version: Netty 4.

Unfortunately, significant code changes are necessary to work on Netty 4. I had a go, but the chunked http stuff has changed significantly, and I never understood the old code, so can't really help.

Change History (1)

comment:1 Changed 12 months ago by sebastic

Cc: sebastic added
Priority: minorcritical

As reported in Debian Bug #888255, netty-3.9 will be removed from Debian which will also cause the removal of the osmosis package.

Osmosis needs to be adapted to use the netty-4.x API.

Note: See TracTickets for help on using tickets.